Let’s Encrypt – Error using old version

Using the old bash script for automatic renewal sometimes fail with this error (or similar one):

warning:certbot.renewal:attempting to renew cert from produce an unexpected error: the apache plugin is not working; noinstallerror()

This is probably result of two things:

  1. Let’s Encrypt enforce limits on request count and domain count
  2. The official letsencrypt client change to certbot and is ported to few distros

If you are using Debian 8 with apache this is now the recommended way to renew certs:

sudo apt-get install python-certbot-apache -t jessie-backports

#crontab twice per day
certbot renew --quiet

For other configuration check https://certbot.eff.org/

Leave a Reply

Your email address will not be published.

*