Let’s Encrypt – Błąd podczas używania starej wersji klienta

Używanie starego klienta do odnawiania certyfikatów czasami kończy się poniższym błędem (lub podobnym):

warning:certbot.renewal:attempting to renew cert from produce an unexpected error: the apache plugin is not working; noinstallerror()

Wynika to prawdopodobnie z dwóch rzeczy:

  1. Let’s Encrypt wymusiło limity na ilości zgłoszeń oraz domen w zgłoszeniu
  2. oficjalny klient letsencrypt został zastąpiony certbot-em i został przeportowany na różne dystrybucje do repozytoriów

Jeżeli korzystanie z Debian-a 8 i apache, oto rekomendowany sposób odnawiania certyfikatów:

sudo apt-get install python-certbot-apache -t jessie-backports

#crontab dwa razy dziennie
certbot renew --quiet

Rekomendowane sposoby dla innych konfiguracji znajdują sie na https://certbot.eff.org/

Dodaj komentarz

Twój adres email nie zostanie opublikowany. Pola, których wypełnienie jest wymagane, są oznaczone symbolem *

*