Mikrotik – Wysyłanie informacji o klientach łączących się do sieci WiFi

Urządzenia Mikrotik dają bardzo duże możliwości konfiguracyjne, oto bardzo prosty sposób w jaki uzyskać automatyczne rejestrowanie wszelkich logowań/wylogowań z sieci wifi, a następnie w postaci raportu raz dziennie przesłać je na dowolnego maila.

Zakładam, że macie skonfigurowaną opcję wysyłania maili.

Należy ustawić temat logów, które chcemy rejestrowac do pliku (np. wifi.log):

#winbox
system > logging > actions > add > wifilog, type:disk, filename: wifi.log
system > logging > rules > add > topics: wireless, info action: wifilog

#console
/system logging action add name=wifilog disk-file-name=wifi.log target=disk
/system logging add action=wifilog topics=wireless

Następnie tworzymy skrypt którego celem będzie utworzenie kopii logu, wysłanie go, usunięcie kopii oraz usunięcie używanego użytkownika w celu zachowania wysokiego poziomu bezpieczeństwa:

#winbox 
system > scripts > add > name: event_wifi

#console
/system script add name=event_wifi

#wklejamy zawartość skryptu:
/user group add name=wifi policy=ftp,read comment="wifi log"
/user add name=wifi group=wifi address=127.0.0.1 comment="wifi log" password=your_password disabled=no
/tool fetch address=127.0.0.1 mode=ftp user=wifi password=your_password src-path=wifi.log.0.txt dst-path=wifi34.txt
:delay 10
/tool e-mail send file=wifi.txt to="your_email@example.com" body="raport" subject=([/system identity get name] . " " . [/system clock get time] . " " . [/system clock get date] . " WiFi Log")
/file set wifi.log.0.txt contents=""
:delay 30
/file remove wifi.txt
/user remove "wifi"
/user group remove "wifi"

 

Pamiętajmy, aby ustawić w harmonogramie uruchamianie skryput raz dziennie:

#winbox
system > scheduler > add > name: wifi interval: 24:00:00 on event: event_wifi

#console
/system scheduler add name=wifi interval=24:00:00 on-event=event_wifi

 

Dodaj komentarz

Twój adres email nie zostanie opublikowany. Pola, których wypełnienie jest wymagane, są oznaczone symbolem *

*